Install PyCharm Python IDE on Ubuntu Linux + Create and Run First Project

Video is ready, Click Here to View ×

install Oracle Java by following commands

$ sudo add-apt-repository ppa:webupd8team/java
$ sudo apt-get update
$ sudo apt-get install oracle-java8-installer

How To Install PyCharm On Ubuntu 14.04, Linux Mint 17
How to update PyCharm 3.4 to 4 in Ubuntu 14.04
Installing PyCharm
Searches related to install pycharm
install pycharm mac
install pycharm professional ubuntu
install pycharm debian
install pycharm fedora
install pycharm centos
pycharm 2
pycharm 2.5 keygen
pycharm 2.5 key


  1. Thanks for the video. While installing Java I got the following message

    gpg: keyring `/tmp/tmpm2els_jf/secring.gpg' created
    gpg: keyring `/tmp/tmpm2els_jf/pubring.gpg' created
    gpg: requesting key EEA14886 from hkp server
    gpg: /tmp/tmpm2els_jf/trustdb.gpg: trustdb created
    gpg: key EEA14886: public key "Launchpad VLC" imported
    gpg: no ultimately trusted keys found
    gpg: Total number processed: 1
    gpg: imported: 1 (RSA: 1)

    What to do next?

  2. I always think about how the setup files are made. As I wrote program in C,C++ and JAVA but I don't know how to make icon such that on double click my program runs.
    I make program to work as a calculator, but every time I want to run the program, I have to run the source code….Plz anyone tell me about this topic..!!

  3. hello
    I face some trouble with the third commend "sudo apt-get install oracle-java8-installer"
    can you find the error
     " Reading package lists… Done
    Building dependency tree
    Reading state information… Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:

    The following packages have unmet dependencies:
    oracle-java8-installer : Depends: java-common (>= 0.24) but it is not installable
    Recommends: gsfonts-x11 but it is not installable
    E: Unable to correct problems, you have held broken packages"

Leave a Reply

Your email address will not be published.